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E l e c t r o s t a t i c  Po t e n t i a l  B e twe en 
C y l i n d e r s

This example model demonstrates each step in building and solving a 3D electrostatics 
model. The analysis shows the electric potential between two cylinders in a vacuum.

Model Definition

The first step is to define the overall model and draw its geometry. This model consists 
of two cylinders with opposite electrostatic potentials. The potential difference 
between them induces an electric field in the vacuum. The electrostatic scalar potential 
V is related to an electric field as E ∇V–= . Gauss’ law, ∇ ε E( )⋅ ρ= , gives 

∇ ε∇V( )⋅– ρ= .

This equation includes a material property and a source term:

• ε is the permittivity.

• ρ is the space charge density.

To simulate the vacuum chamber, create a box in which there is no atmosphere or gas 
of any kind. In addition, assume that the potential is zero on the bottom boundary and 
that there is no electric field normal to the other exterior boundaries.

Results

The plot in Figure 4-1 on page 54 combines a surface plot of the potential with a 
streamline plot of the electric field. The surface plot shows the electric potential on the 
cylinder and box faces. As expected, the electric field lines run from cylinder to cylinder 
and from the cylinders to the grounded bottom plate. The electric field does not 
penetrate the top and side walls.
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Figure 4-1: The electric potential (surface) and the electric field (streamlines).

Modeling Using the Graphical User Interface

Start COMSOL Multiphysics using the procedure for the operating system on your 
computer. On Windows double-click the COMSOL Multiphysics icon to start COMSOL 
Multiphysics and open the Model Navigator.

Model Library path: COMSOL_Multiphysics/Electromagnetics/
potential_between_cylinders

M O D E L  N A V I G A T O R

For this model use the Electrostatics application mode.

1 In the Model Navigator click on the New tab.

2 Select 3D in the Space dimension list.
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3 In the list of application modes, open the COMSOL Multiphysics folder and then the 
Electromagnetics folder. Select Electrostatics from the list of electromagnetics 
application modes. 

4 Accept the default element type (quadratic Lagrange elements), which is suitable for 
most cases.

5 Click OK.

The Electrostatics application mode provides predefined equations and boundary 
conditions that make it easy to create this model, but you must still attend to a few 
details.

O P T I O N S  A N D  S E T T I N G S

In this model the permittivity of free space, ε0, defines the permittivity in the domain. 
It is not necessary to enter this variable because it is a predefined application scalar 
variable in the Electrostatics application mode. If you prefer to use another value rather 
than the standard SI unit value, choose Scalar Variables from the Physics menu. Doing 
so, however, changes the underlying formulation for electrostatics, so we recommend 
that you use the predefined value.

G E O M E T R Y  M O D E L I N G

Next define the model geometry. For this example, create a box measuring 2 × 2 × 2 
meters, and then place two cylinders inside that box. When you exit the Model 
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Navigator to begin setting up a model, COMSOL Multiphysics enters Draw mode with 
access to the drawing tools.

To define the model geometry, begin with the box:

1 Open the Block dialog box by clicking on the appropriate symbol on the Draw 
toolbar.

2 In that dialog box, go to the Base area and click the Center button to use centered 
base coordinates.

3 In the Length area, type 2 in the X, Y, and Z edit fields as the length for all three 
dimensions.

4 Click OK to create the block.

5 To ensure that the full geometry is visible, click the Zoom Extents button.

Now move on to the two cylinders. To create these 3D objects on a 2D screen, work 
in a 2D work plane. The method to follow in creating the cylinders is simple: draw two 
circles in 2D and then extrude them in the z-direction to form 3D objects.

1 Go to the Draw menu and choose Work Plane Settings to define a new work plane.

2 Click on the Quick tab and select the x-y check box (the default).

3 Type -0.2 in the z edit field.

4 Click OK to enter the 2D work plane.

Now draw the cylinder cross sections in the work plane:

1 Click on the Zoom In button several times until the grid spacing equals 0.2 in both 
the x- and y-directions.

2 Go to the Options menu and choose Axes/Grid Settings.

3 In the Axes/Grid Settings dialog box click on the Grid tab.
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4 Clear the Auto check box and type 0.1 in the y spacing edit field.

5 Click OK. You can now create circles with a radius of 0.1.

6 Click on the Ellipse/Circle (centered) button in the Draw toolbar.

7 Place the crosshairs at the coordinates (-0.4, 0). Then click on the right mouse 
button and drag up or down until you create a circle with radius of 0.1.

8 Repeat the process to draw a second circle of the same size centered at (0.4, 0).

Create the cylinders:

1 Press Ctrl+A to select both circles.

2 Go to the Draw menu and choose Extrude.

3 In the Extrude dialog box define the height of the cylinders by typing 0.4 in the 
Distance edit field. The resulting cylinders extend from –0.2 to 0.2 in the z-direction.

4 Click OK to close the dialog box.

COMSOL Multiphysics now returns to the 3D environment where the cylinders are 
present. The cylinders have become extruded geometry objects with the names EXT1 
and EXT2.

To complete the geometry, subtract the two cylinders from within the box using a 
Boolean operation:

1 Click on the Create Composite Object button in the Draw toolbar.

2 In the Create Composite Object dialog box, control-click to select all the objects in 
the Object selection list. 

3 Type the Boolean expression BLK1-EXT1-EXT2 in the Set formula edit field.

4 Click OK.

The resulting geometry is a new composite object with the default label CO1.
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P H Y S I C S  M O D E L I N G

The next task is to define the physics through material properties on the domain and 
conditions on the boundaries.

Boundary Conditions
To set boundary conditions:

1 Enter the Boundary Selection mode by clicking on the corresponding toolbar 
button, or go to the Physics menu, point to Selection Mode and then click on 
Boundary Mode.

2 Go to the Physics menu and choose Boundary Settings to open up the corresponding 
dialog box. Here you select boundaries and specify the boundary conditions.

When you select a specific boundary, the program allows you to choose from a list of 
available boundary conditions.

To speed the modeling process even with a relatively simple 3D model, you can select 
several faces with one mouse click. To learn more about the various selection methods 
see “Object Selection Methods in 3D” on page 127 in the COMSOL Multiphysics 
User’s Guide.
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The following table summarizes the boundaries in this model and their values:

BOUNDARY 6–11 12–17 1–2, 4–5, 18 3

Type Electric potential Electric potential Zero charge/Symmetry Ground

V0 1 -1

• Boundaries 6–11 define the left cylinder where the electric potential is 1 V.

• The second cylinder consists of boundaries 12–17 and has an electric potential of −1 
V.

• The third set of boundaries defines the box, except the bottom boundary.

• The last set (boundary 3) is the grounded bottom plate.

To enter these boundary values into the model, follow these steps:

1 To enable object selection with the mouse you must first deselect the Orbit/Pan/
Zoom function. To do so, click on the Orbit/Pan/Zoom button.

2 Draw a rubber-band box around one of the cylinders.

3 When its faces are highlighted, select Electric potential from the Boundary condition 
list.

4 Type 1 in the V0 edit field.

5 Repeat the procedure for the second cylinder, but this time type –1 in the V0 edit 
field.

6 Select the Select by group check box.

7 Select boundary 1. The group selection then also selects all other exterior 
boundaries.

8 Select Symmetry from the Boundary condition list.

9 To select the bottom face, first click to clear the Select by group check box and then 
select boundary 3.

10 Select Ground from the Boundary condition list.

11 Click OK.

Subdomain Settings
Finally, before starting the solution process it is necessary to set material properties in 
the modeling domain.



60 |  C H A P T E R  4 :  E L E C T R O M A G N E T I C S  M O D E L S

Open the Subdomain Settings dialog box from the Physics menu. COMSOL 
Multiphysics then switches to Subdomain Selection mode where you can specify 
material properties for each subdomain.

In this example, ε equals the permittivity of free space ε0 = 8.854·1012, a value 
predefined in COMSOL Multiphysics. The relative permittivity εr then equals 1.

SUBDOMAIN 1

εr 1

ρ 0

The space charge density option specifies the distribution of a space charge in a 
subdomain. Here there is none, so the value of ρ equals zero.

Now set the value for the permittivity in the model:

1 This model consists of only one subdomain. Make certain that subdomain 1 is 
selected in the Subdomain selection list.

2 Go to Constitutive relation and make certain that the default D=ε0εrE is selected.

3 Verify that the default value of 1 appears in the Relative permittivity (isotropic) edit 
field.

4 Click OK.

For time-dependent and nonlinear analyses you might find it necessary to set initial 
conditions. That step is not necessary for this linear electrostatics problem.
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M E S H  G E N E R A T I O N

Generating the mesh is usually quite simple: just click one of the mesh buttons on the 
Main toolbar. In cases with special requirements you can also use commands in the 
Mesh menu. In this case, use a predefined setting for creating a coarse mesh, which 
makes the solution process faster than the default mesh-size settings.

1 From the Mesh menu, choose Free Mesh Parameters.

2 In the Free Mesh Parameters dialog box, select Coarser from the Predefined mesh sizes 
list.

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

At this point you can either accept the default settings for the solver COMSOL 
Multiphysics should use, or you can interactively select the solver and its operating 
parameters. In most cases, though, you only need to click on the Solve button in the 
Main toolbar.

To reduce the time and memory requirements for the solution process, it is wise to 
make a few changes to the solver parameters. The default settings for 3D electrostatics 
models specify an iterative solver. These solvers generally use less memory than direct 
solvers and are often faster.

Iterative solvers work with a set of preconditioners, and the algebraic multigrid 
(AMG) preconditioner works best for scalar elliptic PDEs such as Laplace’s equation 
and Poisson’s equations. It is the default preconditioner for the 3D Electrostatics 
application mode.

1 From the Solve menu, open the Solver Parameters dialog box.

2 Click the General tab.

3 Choose a linear system solver. Select GMRES in the Linear system solver list. 

4 Choose a preconditioner. Select Algebraic multigrid in the Preconditioner list.
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5 Click OK.

6 Start the solution process by clicking on the Solve button in the Main toolbar. The 
results might take a few seconds to compute depending on the problem’s 
complexity

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

After solving the problem, COMSOL Multiphysics shifts to its postprocessing mode 
and shows a slice plot of the electric potential V. This plot, however, might not offer 
much immediately useful information, but COMSOL Multiphysics provides a variety 
of color plots and animations that help you more quickly spot trends and regions of 
interest. To better examine the solution for an electrostatic problem, for instance, you 
might want to view a surface or contour plot, and as the variable of interest you can 
select the electrostatic potential, the electric field, the electric displacement field, or the 
polarization field. Further, for arrow or streamline plots it is possible to select the x, y, 
or z components of most of those parameters.

To combine a surface plot with a flow plot, follow these steps:

1 Choose Plot Parameters from the Postprocessing menu.

2 Clear the Slice check box to deactivate the slice plot.

3 Select the Boundary and Streamlines check boxes to activate these features.
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4 Click on the Streamline tab.

5 Type 30 in the Number of start points edit field on the Start Points tab.

6 Click OK.

You should immediately notice that the surface plot obstructs the view, making it 
impossible to see inside the box. To remove the rendering of the front faces, use the 
ability of COMSOL Multiphysics to suppress boundaries.

1 In the Options menu, point to Suppress and then click Suppress Boundaries.

2 While holding down the Ctrl key, select boundaries 1, 2, and 4 in the Boundary list.

3 Click OK to close the dialog box and render all boundaries except 1, 2, and 4.

4 To add lighting to the model, click on the Scenelight and Headlight buttons in the 
Camera toolbar.
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S ph e r i c a l  C apa c i t o r

Introduction

This example is a study of a capacitor consisting of two spherical copper conductors 
separated by glass.

You can compute the capacitance of a capacitor in two ways. By definition, the 
capacitance is given from the expression

C Q
V12
---------=

where V12 is the voltage difference between the two conductors, and Q is the charge 
of the two conductors, positive and negative, respectively, when connected in a DC 
circuit.

The energy required to charge a capacitor is given by the expression

We
Q2

2C
--------=

The energy defined above should equal the energy of the electrostatic field:

We D E⋅ Vd
Ω
∫=

With the latter being readily available in the Electrostatics application mode, the 
capacitance reduces to the following simple expression

C Q2

2We
-----------=

With the second method, an analytical expression for capacitance is calculated and used 
as a comparison to the numerical solution. Assume charges +Q and −Q on the inner 
and outer spherical conductor, respectively. Applying Gauss’s law to a spherical surface, 
with radius R (Ri < R < Ro), gives

E Q

4πεR2
-----------------er=
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Ri and Ro are here the radii of the two spheres. The potential difference between the 
spheres is then

V E er⋅ Rd

Ro

Ri

∫–
Q

4πε
--------- 1

Ri
------ 1

Ro
-------–⎝ ⎠

⎛ ⎞= =

From this equation it is possible to compute the capacitance,

C Q
V
---- 4πε 1

Ri
------ 1

Ro
-------–⎝ ⎠

⎛ ⎞⁄= =

Model Definition

In COMSOL Multiphysics, you solve the spherical capacitor problem using the 
axisymmetric 2D Electrostatics application mode. It is easy to compute the capacitance 
from the COMSOL Multiphysics user interface using the available integration tools.

D O M A I N  E Q U A T I O N S

The electric scalar potential V, must obey Poisson’s equation,

∇ ε0εr V∇( )⋅– ρ=

where ε0 is the permittivity of free space, εr is the relative permittivity and ρ is the space 
charge density. The electric field and displacement are obtained from the gradient of V

E V∇–=

D ε0εrE=

B O U N D A R Y  C O N D I T I O N S

A ground potential boundary condition describes the condition at the outer electrode. 
At the inner electrode, the boundary condition gives the surface charge:

n– D⋅ ρs=

On the symmetry axis a symmetry boundary condition is applied.
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Model Library path: COMSOL_Multiphysics/Electromagnetics/
spherical_capacitor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) in the Space dimension list.

2 In the list of application modes, select 
COMSOL Multiphysics>Electromagnetics>Electrostatics.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Axes/Grid Settings.

2 Set axis and grid settings according to the following table.

AXIS GRID

r min -0.2 r spacing 0.05

r max 0.3 Extra r 0.19

z min -0.2 z spacing 0.05

z max 0.2 Extra z

3 In the Constants dialog box, enter the following variable name and expression.

NAME EXPRESSION

Q0 5e-12

G E O M E T R Y  M O D E L I N G

1 Draw a circle C1 with radius 0.19 centered at (0, 0).

2 Draw a circle C2 with radius 0.05 centered at (0, 0).

3 Draw a rectangle with opposite corners at (-0.2, -0.2) and (0, 0.2).

4 Open the Create Composite Object dialog box from the Draw toolbar or the Draw 
menu.

5 Form a composite object by typing C1-(C2+R1) in the Set formula edit field.
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6 Click OK to close the dialog box, then click the Zoom Extents button.

P H Y S I C S  S E T T I N G S

Boundary Conditions
Enter boundary conditions according to the following table.

BOUNDARY 1,2 4,5 6,3

Type Axial symmetry Surface charge Ground

ρs Q0/(4*pi*0.05^2)

Subdomain Settings
In this model, use the materials library for defining the material properties:

1 Open the Subdomain Settings dialog box, and select subdomain 1.

2 Click the Load button to open the Materials/Coefficients Library dialog box.

3 Select Glass (quartz) from the materials list and click OK.

4 Now the defined material is used in the subdomain settings.

M E S H  G E N E R A T I O N

1 Initialize the mesh.

2 Refine it once.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The resulting electrostatic potential is zero at the outer conductor and positive and 
constant at the inner conductor as shown in the default surface plot of V.

Capacitance Calculation
The capacitance of the capacitor can be computed using the available postprocessing 
functionality in COMSOL Multiphysics:

1 Select Boundary Integration from the Postprocessing menu and integrate the 
expression V/(0.05*pi) for boundaries 4 and 5. This gives an average value of 
0.157676 for the potential on the inner conductor.

2 Select Subdomain Integration from the Postprocessing menu, check Compute volume 

integral and integrate the Electric energy density We_es. This gives a value of 
3.941853·10−13 for the total electric energy. You can compute the capacitance in 
two different ways:

C1 = Q/V;

which gives the result
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C1 = 3.171060e-011

and

C2 = Q^2/(2*We);

which gives the result

C2 = 3.171097e-11

Compare this to the analytical result.

C0 = 4.2*4*pi*8.854e-12/(1/0.05-1/0.19);

which gives the result

C0 = 3.170985e-011

The energy approach clearly gives the best result.
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Examp l e :  E l e c t r i c  S e n s o r

This is a model from electric impedance tomography, a method of imaging the interior 
permittivity distribution of an object by measuring current and voltage at the surface. 
The technique is used in, for example, medical diagnosis. Because different organs have 
different properties, you can “see” the organs and their movement from the outside.

The model shows how you can determine the shape and the placement of small objects 
with different material properties inside a closed box from outside. Applying a 
potential difference on the boundaries of the box gives rise to a surface charge density 
that varies depending on the permittivity distribution inside the box. By looking at the 
surface charge density you can therefore see the shape of the different materials inside 
the box.

Model Definition

This model solves Gauss’ law with ρ=0.

∇ ε0εr∇V( )⋅– ρ=  

The box contains air with εr equal to 1 and the different objects are made of material 
with different values of the relative permittivity, εr: 1, 2, and 3.

To get a voltage difference, set V = 0 on the bottom and V = 1 on top of the box. On 
all the other boundaries, use an electric insulation condition: n D⋅ 0=

Results and Discussion

The surface charge density is higher above material with higher permittivity as 
expected. You can clearly see the shape of the figures inside the box on the top surface 
in the following plot.
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Inside the geometry the streamlines show how the electric field varies. The gradient of 
the electric field is lower in media with larger value of the permittivity.

Model Library path: COMSOL_Multiphysics/Electromagnetics/
electric_sensor

Modeling Using the Graphical User Interface

1 Open COMSOL Multiphysics.

2 In the Model Navigator, change the space dimension to 3D and select COMSOL 

Multiphysics>Electromagnetics>Electrostatics in the list of COMSOL Multiphysics 
application modes.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Select Work Plane Settings from the Draw menu. Set z to 0.1 and click OK.
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2 Select Axes/Grid Settings from the Options menu.

3 Enter the following data:

AXIS PAGE

x min -2

x max 3

y min 0

y max 3

GRID PAGE

x spacing 0.5

y spacing 0.5

4 Draw a rectangle by clicking on the Rectangle/Square button and then clicking at the 
points (−1, 0.5) and (−0.5, 2.5).

5 Specify two rectangles by selecting Specify Objects and Rectangle from the Draw 
menu. Use the following data:

R2 R3

width 1.5 1.5

height 0.25 0.25

x -1.5 -1.5

y 1 1.75

6 Select all objects by pressing Ctrl+A. Click the Union button and then the Delete 

Interior Boundaries button.

7 Draw an ellipse by pressing the Ellipse/Circle (Centered) button. Click (1.5, 1.5) and 
(0.5, 1).

8 Draw another ellipse clicking at the points (1.5, 1.5) and (1, 0.5).

9 Open the Create Composite Object dialog box and select E1 and E2. Clear the Keep 

interior boundaries check box, and click OK.
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10 Select Extrude from the Draw menu, select both objects and enter 0.8 as distance. 
Click OK.

11 Click the Block button. Enter the following dimensions and base point coordinates 
to create a block:

BLOCK BLK1

Length Axis base point

x 5 -2

y 3 0

z 1 0

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Press Ctrl+A to select all boundaries. Set the boundary condition to Electric 

insulation.

3 Select boundary 3 and set the boundary condition to Ground.

4 Select boundary 4 and set the boundary condition to Electric potential and V0 to 1.
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Subdomain Settings
In the Subdomain Settings dialog box, set the following values of εr:

SUBDOMAIN 1 2 3

εr 1 2 3

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box and select Fine from the Predefined mesh 

sizes list on the General tab. Click OK to close the dialog box.

2 Click the Initialize Mesh button in the Main toolbar to initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Solve the model by clicking on the Solve button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box.

2 On the General page clear the Slice check box and select the Boundary and Streamline 
check boxes.

3 Click the Boundary tab.

4 Under Boundary data, select Surface charge density in the Predefined quantities list.

5 Click the Streamline tab.

6 Click the Use expression to color streamlines button. Then click the Color Expression 
button and set the color data to Electric potential in the Predefined quantities list.

7 Type 100 in the Number of start points edit field.

8 Select Tube in the Line type list.

9 Click the Tube Radius button and set the Radius data to Electric field, norm.

10 Click OK.

To see the streamlines inside the box you must to suppress some of the boundaries:

1 On the Options menu, point to Suppress and then click Suppress boundaries.

2 In the dialog box select boundaries 1, 2, and 6–37.

3 Open the Plot Parameters dialog box and click OK.
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